Graphics related segfaults possibly solved

I’d seen some other reports of segfaults when plotting FF data.

On my earlier Ubuntu Beaver install I had sporadic graphics failures and
now with Focal some things reliably created segfaults like “fill=1” in plot.
Earlier I had posted a stack trace but hadn’t bothered to track it down
due to more interest in my own general purpose viewer ( “datascope”).
However, it recently go so bad I couldn’t work on my phse boundary plots
and even “vlc” failed although for viewing my own movies apparently
“mpv” still worked.

In my case the issue was the mesa drivers… Building them to a local
directory to avoid pollution and exporting the following,

marchywka@happy:/home/documents/cpp/proj/datascope$ export LIBGL_DRIVERS_PATH=/home/ubuntu/dev/mesa/mesa-20.3.5/build/lib/x86_64-linux-gnu/dri

appears to stop failures in vlc and in the reliable FreeFEM failures.

I’m not sure it works for everyone but initial results have been completely successful.

Let me know if this works or not. Building mesa required I go get a lot of
stuff but once installed in a sandbox the one export seems to work.,