Excluding "-g" option when compiling

How can I make configure script to exclude the debug “-g” option? It includes -g even when we have --enable-optim to produce an optimized binary.

It’s there by default. You can remove the debug symbol using the strip binary.

Sorry, I think you can just ./configure --disable-debug --enable-optim CFLAGS="" CXXFLAGS="", it should work.

Thanks! this works and -g is gone