Specifying freeglut library and include directories

Dear developers,

I need to compile freefem on a machine without administrator rights, and I need graphics.
I installed freeglut manually in some local directory. I do not understand how to specify the directory correctly since the configure option “–with-glut” does not seem to take any argument.

Right now I just add the right path to the CFLAGS and CPPFLAGS. However these are not taken into account during the compilation of picking.c in the medit Makefile, which results in an error because GL/glut.h is not found. I solve the problem by adding the CFLAGS to picking.c, but I feel this is not the right way to do it…

Any insight about that?

Many thanks