Suppress "-options_left" when using PETSc

Hi all,

It seems there may have been a change in the default verbosity when using PETSc in FreeFEM. Since updating my FF build, I’ve gotten a lot more output even with -v 0. Is there a way to force-suppress these new warning messages? (example below)

WARNING! There are options you set that were not used!
WARNING! could be spelling mistake, etc!

I believe this may be linked to the -options_left PETSc argument.


This is a change in PETSc, not FreeFEM. Previously, this was only displayed with debug builds, but now it also shows up in optimized builds. You can skip this specific message using the additional option -options_left no (or false, or 0).

1 Like