Issue configuring PETSc during FF installation on Mac

Hello,

I am trying to install FreeFEM v 4.6 on my mac (macOS Big Sur version 11.0.1) via the terminal using the source code, and I come across this issue while trying to configure PETSc:

===============================================================================
Configuring PETSc to compile on your system

TESTING: checkFortranCompiler from config.setCompilers(config/BuildSystem/config/setCompilers.py:960) *******************************************************************************
UNABLE to CONFIGURE with GIVEN OPTIONS (see configure.log for details):

Fortran compiler you provided with --with-fc=/usr/local/bin/mpif90 cannot be found or does not work.
Cannot compile/link FC with /usr/local/bin/mpif90.


make: *** [petsc-3.13.0/tag-conf-real] Error 1

I am not sure how to properly complete installation.

Thank you.

Please try again with FreeFEM 4.8 and let me know if this is fixed. If not, please attach both config.log and 3rdparty/ff-petsc/petsc-3.14.2/configure.log.

Hello,

I tried installing v4.8 and I was able to successfully configure PETSc; however I run into a different issue trying to build the FreeFEM library and executable. I have attached a screenshot of the terminal output.

Thank you.

You should be able to configure with --disable-freeyams to fix this issue.

Okay. Which config file should I change to implement that command?

config.param, then ./reconfigure.

I tried that but it’s not working either. It says it’s an unrecognized option:

configure: WARNING: unrecognized options: --disable-freeyams

Sorry, please try --disable-yams instead.

I think that helped, but now I’m trying to run examples and I get this error message:

dyld: Library not loaded: @rpath/libhdf5.103.dylib

You have some HDF5 files lying around which have been picked up by configure.
Please also add '--without-hdf5'.

It worked! Thank you very much.