Critical issues with getall to download 3rdparty dependencies

Dear all,

As explained in the title, I encounter critical issues in downloading 3rd party libraries upon rebuilding FreeFem++ after fresh ubuntu 24.04 installation. All configuration is fine except the getall part (see the output for getall getall.log (10.4 KB) ).

Does anyone know what can be the issue?
Thanks for the help!

Could you try switching to the develop branch?

I do this to update: git pull origin develop so I should be on the develop branch right?

If I type git branch -a I get:

  • master
    remotes/origin/HEAD → origin/master

No, you also need to git checkout develop (sorry for the delay, tough day at work).

I did change to the develop branch, the problem with ./3rdparty/getall -a persists. Several 3rd party fail to be downloaded, for example MUMPS:

Error download pkg/MUMPS_5.0.2.tar.gz
Download failed from of MUMPS_5.0.2.tar.gz
Try other site:
Error download pkg/MUMPS_5.0.2.tar.gz
Download 2 times failed from of MUMPS_5.0.2.tar.gz
Try (2 times) other site:

See getall.log (10.4 KB) for full log of the download

As a matter of fact I just tried on another machine (ubuntu 20.04) that have a perfectly functionning FreeFem++ v4.14, and I get the very same error with 3rdparty/getall

It looks very much like an error that was reported previously on this thread and seemed to be due to backup server was not up-to-date according to this answer

I have also found this error on MacOS. (issue here)
It seems there is not much effort to maintain the 3rdparty/getall build process. If you use the PETSc interface, you can skip the 3rdparty/getall step and get access to MUMPS and several other libraries that way.

Right, I’ve given up updating 3rdparty/getall except for PETSc, so you should not expect other packages to be downloaded properly until someone else does the job.

Some links in the to download the 3rdparty are broken.
To overcome this problem, you can edit yourself the link in the file “getall” of folder 3rdparty, similarly as


you may need to adjust the md5 checksum for some files.
just download the hosted file from

and get the md5 check sum from

If you’ve done this, it would be nice to submit a pull request with your fixes to help other users!

It is not too bad to let the other users learning how to do this. I would have uploaded my getall file here if I were not restricted by the new users limitation.
At the end, it is just a matter of replacing the url link in the download link which fails and adjust their md5 checksum.

I think maybe you could just download all the 3rdparties zips from the github link

GitHub - FreeFem/FreeFEM-3rdparties

and put them in the correct folder.

This help me solve the problem two weeks ago…

Looks like Frederic just patched this in two commits on the develop branch:

The technique to adjust the checksum from a downloaded file should be avoided.
The checksum is meant to recognize a malicious version which would not have the same checksum.

Yes and know, it is also a test to get the correct version.