Problem with linked packages in the getall file

I am trying to make the installation in Ubuntu 20.04, I did this many time on 18.04, but now when I run the command ./3rdparty/getall -a there are many packages that cannot be accessed or downloaded. I checked the getall file trying to access myself from Chrome to some of those links such as :

** ‘’,**
** ‘arpack96.tar.gz’,**
** ‘fffaa970198b285676f4156cebc8626e’);**

but that page does not exist, it is an error. Then, this problem also affects the subsequent installation steps.

I will check the getall script

You can let PETSc install ARPACK (via make petsc-slepc), then, you won’t have issues with getall. Most of the links in getall are out-dated, so you should not rely on them anyway.

It means that I don’t need to use “./3rdparty/getall -a” and then I can skip from step 4 to 6 in the installation instructions?

Many thanks

I don’t know what installation instructions you are using, almost all of them are also out-dated. If you follow these steps GitHub - FreeFem/FreeFem-sources: FreeFEM source code, you should be good to go.

I was following this, the only difference is the prefix. Then, following the instructions you suggested, as “./3rdparty/getall -a” is not working well because of the getall file is out-dated, I forced all the installations using “make petsc-slepc” directly.
At the end the problem of the links persists when I excecute make -j2, many errors appear.

What do you mean? What errors?

The problem was finally solve apdating in getall the mmg and parmmg packages:

After doing sudo make -j4, the example testvtk.edp in /examples/3dSurf/ did not working, looking at its .log file I commented the last three lines:

//meshL ThL2=vtkloadL(“ThL.vtk”);

This problem was previously reported here

Then I could run sudo make -j4 and sudo make -j4 check, with the following results:

XFAIL: stokes-adapt-3d-PETSc.edp

However, for my purpose parallel freefem is working well now!


Hi everyone,
I am having difficulties to install the last version of FreeFem from sources recently on Ubuntu 22.04.
The errors message that I received seem related to the conversation above.

First: I have following the installation instructions specified in @prj 's message (the instructions link are here: GitHub - FreeFem/FreeFem-sources: FreeFEM source code)

I received an error while executing: ./3rdparty/getall -a

Second, I changed this line with: ./3rdparty/getall -o PETSc -a
I am now stuck with many errors during the final make process. Below is the error message:

34.73 ERROR: ../bin/build/download pkg/freeyams.2012.02.05.tgz  FAILED
34.73 ERROR 2: ../bin/build/download pkg/freeyams.2012.02.05.tgz  FAILED
34.73 ERROR2: INVALID MD5 for freeyams.2012.02.05.tgz  d41d8cd98f00b204e9800998ecf8427e
34.73 make[5]: Leaving directory '/usr/local/src/FreeFem-sources/3rdparty/yams'
34.73 make[5]: *** [Makefile:71: ../pkg/freeyams.2012.02.05.tgz] Error 1
34.73 make[4]: *** [Makefile:1015: compile-dir] Error 2
34.73 make[4]: Leaving directory '/usr/local/src/FreeFem-sources/3rdparty'
34.73 make[3]: *** [Makefile:1024: tag-compile-pkg] Error 1
34.73 make[3]: Leaving directory '/usr/local/src/FreeFem-sources/3rdparty'
34.73 make[2]: *** [Makefile:615: all-recursive] Error 1
34.73 make[2]: Leaving directory '/usr/local/src/FreeFem-sources/3rdparty'
34.73 make[1]: *** [Makefile:808: all-recursive] Error 1
34.73 make[1]: Leaving directory '/usr/local/src/FreeFem-sources'
34.73 make: *** [Makefile:758: all] Error 2

I have tested some modifications, but now I am running out of ideas to move forward with the installation. Do you deem the problem is only related to the getall file?

Could you simply go into the src subfolder and type make ?

Ok, I have tried to rebuild FreeFem from sources, by doing:

autoreconf -i
./configure --enable-download --enable-optim --prefix=/usr/local/freefem/
./3rdparty/getall -o PETSc -a
cd 3rdparty/ff-petsc
make petsc-slepc
cd -

Finally I have done:

cd src && make

Upon running make, I get this error:

make[1]: Entering directory '/usr/local/src/FreeFem-sources/src/mpi'
cp ../fflib/ffapi.cpp .
depbase=`echo ffapi.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`;\
/usr/bin/mpic++ -DHAVE_CONFIG_H -I. -I../..  -DPARALLELE -I./../fflib -I./../Graphics -I./../femlib -I./../bamglib/ -I/usr/include/x86_64-linux-gnu/mpich  -I/usr/include -I/usr/include/hdf5/serial -I/usr/local/freefem/ff-petsc/r/include -I/usr/local/freefem/ff-petsc/c/include -DWITH_bemtool -DWITH_htool -I./../../3rdparty/include/BemTool/ -I./../../3rdparty/boost/include -I../../plugin/mpi  -DPARALLELE -DHAVE_ZLIB -g -O2 -DNDEBUG -O3 -mtune=generic -std=gnu++14 -DBAMG_LONG_LONG  -DNCHECKPTR -fPIC -MT ffapi.o -MD -MP -MF $depbase.Tpo -c -o ffapi.o ffapi.cpp &&\
mv -f $depbase.Tpo $depbase.Po
depbase=`echo ../lglib/mymain.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`;\
/usr/bin/mpic++ -DHAVE_CONFIG_H -I. -I../..  -DPARALLELE -I./../fflib -I./../Graphics -I./../femlib -I./../bamglib/ -I/usr/include/x86_64-linux-gnu/mpich  -I/usr/include -I/usr/include/hdf5/serial -I/usr/local/freefem/ff-petsc/r/include -I/usr/local/freefem/ff-petsc/c/include -DWITH_bemtool -DWITH_htool -I./../../3rdparty/include/BemTool/ -I./../../3rdparty/boost/include -I../../plugin/mpi  -DPARALLELE -DHAVE_ZLIB -g -O2 -DNDEBUG -O3 -mtune=generic -std=gnu++14 -DBAMG_LONG_LONG  -DNCHECKPTR -fPIC -MT ../lglib/mymain.o -MD -MP -MF $depbase.Tpo -c -o ../lglib/mymain.o ../lglib/mymain.cpp &&\
mv -f $depbase.Tpo $depbase.Po
depbase=`echo ../lglib/ | sed 's|[^/]*$|.deps/&|;s|\.o$||'`;\
/usr/bin/mpic++ -DHAVE_CONFIG_H -I. -I../..  -DPARALLELE -I./../fflib -I./../Graphics -I./../femlib -I./../bamglib/ -I/usr/include/x86_64-linux-gnu/mpich  -I/usr/include -I/usr/include/hdf5/serial -I/usr/local/freefem/ff-petsc/r/include -I/usr/local/freefem/ff-petsc/c/include -DWITH_bemtool -DWITH_htool -I./../../3rdparty/include/BemTool/ -I./../../3rdparty/boost/include -I../../plugin/mpi  -DPARALLELE -DHAVE_ZLIB -g -O2 -DNDEBUG -O3 -mtune=generic -std=gnu++14 -DBAMG_LONG_LONG  -DNCHECKPTR -fPIC -MT ../lglib/ -MD -MP -MF $depbase.Tpo -c -o ../lglib/ ../lglib/ &&\
mv -f $depbase.Tpo $depbase.Po
cp ../fflib/compositeFESpace.cpp .
depbase=`echo compositeFESpace.o | sed 's|[^/]*$|.deps/&|;s|\.o$||'`;\
/usr/bin/mpic++ -DHAVE_CONFIG_H -I. -I../..  -DPARALLELE -I./../fflib -I./../Graphics -I./../femlib -I./../bamglib/ -I/usr/include/x86_64-linux-gnu/mpich  -I/usr/include -I/usr/include/hdf5/serial -I/usr/local/freefem/ff-petsc/r/include -I/usr/local/freefem/ff-petsc/c/include -DWITH_bemtool -DWITH_htool -I./../../3rdparty/include/BemTool/ -I./../../3rdparty/boost/include -I../../plugin/mpi  -DPARALLELE -DHAVE_ZLIB -g -O2 -DNDEBUG -O3 -mtune=generic -std=gnu++14 -DBAMG_LONG_LONG  -DNCHECKPTR -fPIC -MT compositeFESpace.o -MD -MP -MF $depbase.Tpo -c -o compositeFESpace.o compositeFESpace.cpp &&\
mv -f $depbase.Tpo $depbase.Po
compositeFESpace.cpp:17:10: fatal error: bemtool/tools.hpp: No such file or directory
   17 | #include <bemtool/tools.hpp>
      |          ^~~~~~~~~~~~~~~~~~~
compilation terminated.
make[1]: *** [Makefile:708: compositeFESpace.o] Error 1
make[1]: Leaving directory '/usr/local/src/FreeFem-sources/src/mpi'
make: *** [Makefile:552: all-recursive] Error 1

I met the same problem like this when I updated my FreeFEM++ from version 4.12 to 4.14.
I thought this might be related to some packages in the 3rdparty/pkg were not downloaded successfully

I finally succeeded when I try “cd src && make” .
(But I thought it might be helpful to download the needed package manually and put them in the folder 3rdparty/pkg… it’s strange that PETSc could not install these packages automatically in some cases, even one year ago I didn’t meet any problem to install version 4.12 )

BemTool is not part of PETSc, most of the other packages are indeed installed by PETSc.