Load PETSc error with FreeFem++

Dear all,

I am trying for the first time to use FreeFem++, I installed it and it seems to work.
However, I tried to work on some examples using PETSc, I installed it and I get always the same error despite reinstalling PETSc open-mpi and reinstalling even FreeFem++.

The error I always get is the following:

2 : load "PETSc"

load error : PETSc
fail :
dlerror : dlopen(/usr/local/ff++/openmpi-2.1/lib/ff++/3.61-1/lib/PETSc.dylib, 1): image not found
list prefix: ‘./’ ‘/usr/local/ff++/openmpi-2.1/lib/ff++/3.61-1/lib/’ list suffix : ‘’ , ‘.dylib’
Error line number 2, in file mycode.edp, before token PETSc

If someone could help me on this I would really appreciate.

It seems you are trying to load a plugin compiled for FreeFEM version 3.61-1, which is about 5 years old, see in the log /usr/local/ff++/openmpi-2.1/lib/ff++/3.61-1/lib/PETSc.dylib. Please try to make a fresh install, by making sure you don’t have any old FreeFEM files installed somewhere on your machine and following these steps, and if you run into new issues, do let us know.

I don’t know how I ended up downloading a previous version of FreeFEM but it was indeed the issue and it is now solved.

Thanks a lot for your help!