Issue on dual-cpu server with Windows 11

Dear all,
I am unable to use all the cores to run my FreeFEM code.
My FreeFEM version is 4.14 and the OS is Windows11. My machine is equipped with dual AMD 7003 series CPUs, each have 64 cores. My code uses PETSc, it works well with up to around 70 cores, when I keep increasing the number of processes, it will crash.
If I run the code with mpiexec.exe -n 73 FreeFem++-mpi.exe mycode.edp:

Caught signal number 11 SEGV: Segmentation Violation, probably memory access out of range

If I run the code with mpiexec.exe -n 74 FreeFem++-mpi.exe mycode.edp :

Mingw-w64 runtime failure:
  VirtualProtect failed with code 0x5af

Another problem is I cannot launch another FreeFEM routine when the running FF++ occupies about 70 cores, if I do so, all the FF++ will crash.
Is it possible to utilize all the cores?

Yes, it is possible to utilize all the cores, but Windows is not really suitable for such simulations.

Hi prj,
Thanks for your quick responce.
I just installed Ubuntu 24.04 on my machine, and it seems that the argument -wg is disabled.

ff-mpirun -np 128 mycode.edp -wg -v 0
ffglut: error while loading shared libraries: cannot open shared object file: No such file or directory
Linear solve converged due to CONVERGED_ITS iterations 1
KSP final norm of residual 2.45257e-15
0 TS dt 0.01 time 0.
[0]PETSC ERROR: ------------------------------------------------------------------------
[0]PETSC ERROR: Caught signal number 13 Broken Pipe: Likely while reading or writing to a socket
[0]PETSC ERROR: Try option -start_in_debugger or -on_error_attach_debugger
[0]PETSC ERROR: or see and
[0]PETSC ERROR: configure using --with-debugging=yes, recompile, link, and run 
[0]PETSC ERROR: to get more information on the crash.
MPI_ABORT was invoked on rank 0 in communicator MPI_COMM_WORLD
with errorcode 59.

NOTE: invoking MPI_ABORT causes Open MPI to kill all MPI processes.
You may or may not see output from other processes, depending on
exactly when Open MPI kills them.

And I tried serial codes, no graphics windows also.

ffglut: error while loading shared libraries: cannot open shared object file: No such file or directory

I installed FreeFEM as tutorial instructions,

sudo apt-get install libgsl-dev libhdf5-dev

             liblapack-dev libopenmpi-dev freeglut3-dev

dpkg -i FreeFEM_VERSION_Ubuntu_withPETSc_amd64.deb

It seems that everything works nice without -wg, but graphic window is a very nice feature, how to fix it?

Recompile FreeFEM from sources.