Gsl not working in Ubuntu 22

Recently, I installed the latest FreeFem++ v4.11 on a terminal running Ubuntu 22.04 (jammy jellyfish). The installation went without any error, but when I try to run a script that uses the gsl plugin I get the following error:

Load error: gsl
 dlerror : cannot open shared object file: No such file or directory
list prefix: './' '/usr/local/lib/ff++/4.11/lib/' list suffix: '' , '.so'

Then, I started by looking at /usr/local/lib/ff++/4.11/lib/, where I found the shared library, and by looking the versions of the (as far as I know) related libraries, which are:

libc6, version 2.35-0ubuntu3.1
libgcc-s1, version 12.1.0-2ubuntu1~22.04
libgslcblas0, version 2.7.1+dfsg-3
libgsl-dev, version 2.7.1+dfsg-3

all of them in their newest versions. Then I tried to install libgsl23, but I only find the versions for Ubuntu 20.04, so I don’t know what else could I do, as I’m not sure where the problem comes from.

What do you think I should do?

On ubuntu try to recompile gsl.cpp with form a source .

so egt 2 file

on me mac , just change the place of include and lib of gsl
and pust a correct place in the distribution !`

brochet:Downloads hecht$ ff-c++ gsl.cpp -I/opt/homebrew/include -L/opt/homebrew/lib -lgsl
g++ -c '-I/Applications/' '-I/opt/homebrew/include' -Wno-undefined-var-template -m64 -fPIC -DNDEBUG -O3 -O3 -O3 -std=c++14 -DBAMG_LONG_LONG -DNCHECKPTR -fPIC -I/Applications/ -I/opt/homebrew/Cellar/hdf5/1.12.2_2/include -I/opt/homebrew/opt/libaec/include 'gsl.cpp'

g++ -bundle -undefined dynamic_lookup -Wno-undefined-var-template -m64 -fPIC -DNDEBUG -O3 -O3 -O3 -std=c++14 -DBAMG_LONG_LONG -DNCHECKPTR -fPIC -I/Applications/ -I/opt/homebrew/Cellar/hdf5/1.12.2_2/include -I/opt/homebrew/opt/libaec/include 'gsl.o' -o gsl.dylib '-L/opt/homebrew/lib' '-lgsl'
ld: warning: -undefined dynamic_lookup may not work with chained fixups

Thank you so much for the suggestion, now its solved and works properly.