Freefem 4.5 installation on Linux-based cluster (not a sudoer)

Hello all,

I would like to install and compile the Freefem 4.5 version on a cluster, while (as typically is) not being a sudoer. If I naively follow the installation and compilation guide for Ubuntu (Installation guide) I stumble upon sudo commands for which I have no permission in the cluster environment.

An example is:

sudo apt-get update && sudo apt-get upgrade
sudo apt-get install cpp freeglut3-dev g++ gcc gfortran \
     m4 make patch pkg-config wget python unzip \
     liblapack-dev libhdf5-dev libgsl-dev \
     autoconf automake autotools-dev bison flex gdb git cmake
# mpich is required for the FreeFEM parallel computing version
sudo apt-get install mpich

Now, is there an alternative way to skip the above mentioned step and still ensure that the necessary packages are installed locally in my user account within the cluster system?

Any help would be very appreciated.

These instructions are out-dated, and so is FreeFEM 4.5
Simply use the instructions from GitHub - FreeFem/FreeFem-sources: FreeFEM source code, with the --prefix option, and make petsc-slepc step. It will fetch and install everything you need.

1 Like

Dear prj,

thank you for your reply. Your advice led me to some progress and I appreciate that, but the compilation of PETSc failed. The error message is attached, however not very helpful.

The step from GitHub - FreeFem/FreeFem-sources: FreeFEM source code that led to failure was:

make petsc-slepc

Please send 3rdparty/ff-petsc/petsc-3.XY.Z/fr/lib/petsc/conf/make.log and 3rdparty/ff-petsc/petsc-3.XY.Z/fr/lib/petsc/conf/configure.log (you’ll need to adapt 3.XY.Z).

The path you said reads as below in my case:


In this folder I indeed find the files you have mentioned, but because I am a new user, I am not able to send attachments as it seems from the message I get when trying to load attachments here.
Alternatively, you can access the .log files requested from this link: WeTransfer - Send Large Files & Share Photos Online - Up to 2GB Free

Thank you

I believe this is the same problem as in Install FreeFem on cluster. Please edit 3rdparty/ff-petsc/Makefile and add the flag --with-make_np=10 to the COMMON_FLAGS variable.

I have edited the 3rdparty/ff-petsc/Makefile adding the flag --with-make-np=10 to the COMMON_FLAGS variable. You can see it appearing at line 60 of the Makefile downloadable from here:

I also attach to the same link the screen messages resulting from the operation make petsc-slepc.
The error seems to be the same as before.

I might have misinterpreted the location of the --with-make-np=10 option in the Makefile. Please advise if that is the case.

Thank you for your continued support on this issue.

Are you compiling on a login node or on a compute node?
Could you please try the following?

$ cd /rds/general/user/fs2317/home/local/FreeFem-sources/3rdparty/ff-petsc/petsc-3.17.0/
$ make PETSC_ARCH=fr PETSC_DIR=/rds/general/user/fs2317/home/local/FreeFem-sources/3rdparty/ff-petsc/petsc-3.17.0 MAKE_NP=1 MAKE_LOAD=1

Hi @prj,

I am using a login node to compile the PETSc library as well as the other software packages.

The 2 command lines suggested lead to the same error, as seen from the attached .log file.
make.log (14.1 KB)

Could you please try to compile on a compute node instead?