Error running FreeFem++ in ubuntu 19.04

(Roberto Cabrales) #1

Hello there. I get the following error after install FreeFem++ 4.0 on ubuntu 19.04

FreeFem++: error while loading shared libraries: libhdf5.so.103: cannot open shared object file: No such file or directory

Can you help me please?

Thanks in advance.

(Simon Garnotel) #2

Hi,

Did you use the deb package ? If yes, this is a package for Ubuntu 18.04.
Prefer use the AppImage package of FreeFEM 4.1-beta.

Is this solved your problem ?

(Roberto Cabrales) #3

Hi. I follow the instructions in page 5 of the FreeFem Documentation Release 4.0. I will try your sugestion.

Regards.

(Simon Garnotel) #4

You have this error while compiling FreeFEM ?

This is really strange, could you post the return of:

ls /usr/lib/libhdf5.so*

For example, on Arch Linux, I have:

/usr/lib/libhdf5.so  /usr/lib/libhdf5.so.103  /usr/lib/libhdf5.so.103.1.0

Did you have some compilations errors ? Did you perform a make check ?

(Roberto Cabrales) #5

The answer for ls /usr/lib/libhdf5.so* was
ls: no se puede acceder a ‘/usr/lib/libhdf5.so*’: No existe el archivo o el directorio

in english is someone like:
ls: can’t access to ‘/usr/lib/libhdf5.so*’: File or directory doesn’t exists

However, if I write locate libhdf5.so gives
/home/robertocabrales/anaconda3/lib/libhdf5.so
/home/robertocabrales/anaconda3/lib/libhdf5.so.103
/home/robertocabrales/anaconda3/lib/libhdf5.so.103.0.0
/home/robertocabrales/anaconda3/pkgs/hdf5-1.10.4-hb1b8bf9_0/lib/libhdf5.so
/home/robertocabrales/anaconda3/pkgs/hdf5-1.10.4-hb1b8bf9_0/lib/libhdf5.so.103
/home/robertocabrales/anaconda3/pkgs/hdf5-1.10.4-hb1b8bf9_0/lib/libhdf5.so.103.0.0
/usr/lib/x86_64-linux-gnu/hdf5/serial/libhdf5.so
/usr/local/MATLAB/R2018a/bin/glnxa64/libhdf5.so.8
/usr/local/MATLAB/R2018a/bin/glnxa64/libhdf5.so.8.0.1

I’m trying to install again by following the instructions on page 5 of the documentation.

(Simon Garnotel) #6

I think FreeFEM has to use /usr/lib/x86_64-linux-gnu/hdf5/serial/libhdf5.so and not the anaconda version.
@frederichecht did you know how to force the good hdf5 library to be used ?

@rcabrales If you do not use hdf5 you could add --disable-hdf5 in the ./configure step

(Roberto Cabrales) #7

Ok. But, I don’t have idea if my programs use this library…

(Simon Garnotel) #8

It is the case if you use savehdf5sol function in your edp script.
If not you can disable it

(Roberto Cabrales) #9

Here is a part of the result after the command make check…

============================================================================
Testsuite summary for FreeFem++ 4.0
============================================================================
# TOTAL: 38
# PASS:  0
# SKIP:  0
# XFAIL: 14
# FAIL:  24
# XPASS: 0
# ERROR: 0