Same code, different freefem versions, but different results

Hello everybody,
I am new to Freefem. I am experimenting with the code from Bertand Maury and collaborators, found here .

When I run the code with two different Freefem versions the results are different (linux machine, ubuntu).

The version 3.47 provided by ubuntu default package seems to provide reasonable results, but the latest version 4.6 does not.

I definitely am interested to work with the new version and that’s why I am looking for a solution to this issue. I was looking for similar questions in the forum but I didn’t find any. As I am new to Freefem, I am not able to find the reason for the discrepancy of the results.

Thank you for any help.

Removing the two occurences of “solver=Crout” seems to solve the problem

Indeed, without “solver=CROUT” the code produces the same results, regardless the version I use - 4.6 or 3.47. My question is solved. Thank you, very much!

As a message for developers:
With version 4.6, specifying “solver=LU” produces the the same “good” results as without “solver=CROUT”, which may be a sign that CROUT solver has an issue.

Thank you again.