No execution window for FreeFEM++ in Windows 11

Hello everyone,

Recently I met a really strange problem: my execution window for FreeFEM++ disappears when I run a .edp file in Windows 11. For example, if I have a very simple code below

cout << “Hello” << endl;

When I double click the .edp file, no execution window appears anymore. Previously, an execution window like below will appear after running the .edp file


I tried re-intalling FreeFEM++, but the problem still exists. The FreeFEM++ version is 4.9. Wonder how to fix this issue, thanks!

Goodmorning @hezl09,
Not sure on which could be the reson for this issue, but you can easily solve it simply running freefem from the command line: in such a way you’ll be sure to have the output window you are mentioned printed on video!

To do that simply open the command line you are commonly using (cmd, powershell…) and launch the execution with the command:

FreeFem++.exe filename.edp (+ any additional flags if required!)

This will print the output of your code on the screen!

Hope this will help you!

1 Like

Smart solution! Indeed now I can see the execution window and the printed results. Thank you Marco!