Exec MUMPS_mpi error with Edge13d

Hello every one,

I have a problem who works with Edge03d . but when I change it to Edge13d it gives me an execution error :
Erreur Mumps mpi: number -13
Fatal Erreur MUMPS_mpi Factorize
current line = 496 mpirank 0 / 1
Exec error : MUMPS_mpi Factorize
– number :0
** Instance Error 1 in ZMUMPS_F77

Do you know what is the problem?

the error -13 is:
–13 Problem of workspace allocation of size INFO(2) during the factorization or solve steps. The size that the package tried to allocate with a Fortran ALLOCATE statement is available in INFO(2). If INFO(2) is negative, then the size that the package requested is obtained by multiplying the absolute value of INFO(2) by 1 million. In general, the unit for INFO(2) is the number of scalar entries of the type of the input matrix (real, complex, single or double precision).

Thanks for your reply,

do you think I have to simplify my mesh structure to solve this issue or there is another solution?
I tried to calculate magnetic field with edge23d or edge13d for a simple mesh and it was ok, however when I solve a more complex mesh with edge 13d or edge 23d I get this “Mumps mpi: number -13” error.
it works correctly for edge03d.