Error with FreeFem

The ff-mpirun and FreeFem ++ command is not being recognized after finishing the installation of the latest version of FreeFem on my Ubuntu 20.04LTS machineconfig.log (339.7 KB)

You are using a prefix install, so you need to make sure those binaries are in your path.

export PATH=${PATH}:/home/hpc/FreeFem-install/bin

Also, for good measures, you may need to adjust the appropriate include and load paths as follows in ${HOME}/.freefem++.pref.

loadpath += "/home/hpc/FreeFem-install/"
includepath += "/home/hpc/FreeFem-install/path_of_all.idp"

I don’t use make install, so I can’t give you the exact path, but it should be something along lib/ff++/4.7-1/plugin and lib/ff++/4.7-1/idp (maybe? to be checked on your machine).

Thanks prj, It now works well, just a query when I try to print the matrix with the command:
ff-mpirun -np 2 matrix.edp -v 0 -mat_view draw -draw_pause -1
it does not work

Probably because your PETSc is compiled with --with-x=0 (flag put by default if you use make petsc-slepc).
To make sure, you can do the following.

$ cat flags.edp
load "PETSc"
$ ff-mpirun flags.edp -log_view | grep "Configure options"
// check for --with-x=0 in the output