VTK output problem

Dear developers,

I started to use freefeem recently. I am running a code on my computer (win10), but the generated vtk file cannot be read correctly by paraview. However, when I run the same code on another machine (also win10), the vtk files works fine in paraview.

Here I listed some of our obersvations:

1, The code runs fine on both machines. No error reported.
2, On my computer, the generated vtk file has only 2000KB, whereas on the other machine, it is about 4000KB.
3, We tried both 4.5 and 4.6 versions and it remains the same.

So what could be the problem? Could you please give us some suggestions about how to fix it?

Thank you very much,
Best regards,

PS: not sure if it is relevent, but on the other machine, the one with correct vtk output, I got a warning message each time says: “Warning: – Your set of boundary condition is incompatible with the mesh label.”. But the code can still run and the results make sense. This message has never appeared on my machine.

How do you save your data? Please copy/paste your savevtk line here.

Below is my savevtk line:

savevtk(outputFolder+“data_t”+ti+".vtk",Th,MPILoop,rhomtot,rhoftot,Lp11,Lp22,Lp33,Lp12,Lp13,Lp32,Sp11,Sp12,Sp22,Sp31,Sp32,Sp33,S11,S12,S22,S31,S32,S33,T11,T22,T33,T32,T31,T12,T23,phi1vh,phivh,phi2vh,u1,u2,u3,StressNormGlobal,dmgTermGlobal,aDmgGlobal,fNucGlobal,fDmgGlobal,V1DotGlobal,V2DotGlobal,BStimeGlobal,cosAngle,sinAngle,dataname=“MPILoop rhom rhof lp11 lp22 lp33 lp12 lp13 lp32 ep11 ep12 ep22 ep31 ep32 ep33 S11 S12 S22 S31 S32 S33 T11 T22 T33 T32 T31 T12 T23 phi1 phi phi2 u1 u2 u3 StressNorm dmgTerm aDmg fNuc fDmg VDotDiff VDotCreep BStime cosGB sinGB”,order=fforder);

It is the same for both machines.

Thank you!

Change the .vtk extension to .vtu. Does this fix your issue?

It works now. Thank you! We really appreciate.