Unexpected result of electrostatic simulation


I need to do some electrostatic simulations and decided to use FreeFEM for this. After successfully installing FreeFEM 4.10 from source on my Slackware Linux box, I started with the electrostatics example presented in the documentation. Initially it appeared to work as expected but after adding some code, to get also values of the potential displayed, I mentioned some issues. First of all, it looks like the simulation results in regions in which the computed potential is either too large, i.e. larger then the largest value on the boundary, or too small, i.e. smaller then the smallest value on the boundary. Besides, the potential distribution as displayed on the screen during execution looks different than what gets displayed by okular upon opening the generated eps file. I run the code also with a finer mesh but couldn’t mention any significant difference.

Is all this to be expected? How can one avoid obtaining values, which are not conforming to theory? Or at least get the deviations from theory smaller. Is there anything that can be done to have the same displayed on the screen and saved to eps?

Help is highly appreciated.

P.S. I tried to attach two images, got the message that new users are not allowed to do this.