Install Error for additional packages

Whenever I try to do step 6 or 7 of the Windows install guide I get the following:

Sorry missing unzip,m4,bison,flex,patch command

How do I deal with this? Also what exactly should I be putting in mingw64 for the full install?

Type this:

$ pacman -S autoconf automake-wrapper bash bash-completion \
    bison bsdcpio bsdtar bzip2 coreutils curl dash file filesystem \
    findutils flex gawk gcc gcc-fortran gcc-libs grep gzip inetutils info less lndir \
    make man-db git mingw-w64-x86_64-freeglut mingw-w64-x86_64-toolchain mingw-w64-x86_64-gsl mingw-w64-x86_64-hdf5 \
    mingw-w64-x86_64-openblas mintty msys2-keyring msys2-launcher-git \
    msys2-runtime ncurses pacman pacman-mirrors pactoys-git patch pax-git python \
    perl pkg-config pkgfile rebase sed tar tftp-hpa time tzcode unzip util-linux which \
    mingw-w64-x86_64-libmicroutils mingw-w64-x86_64-cmake
$ pacman -R mingw-w64-x86_64-gcc-ada mingw-w64-x86_64-gcc-objc mingw-w64-x86_64-gdb mingw-w64-x86_64-python

It’s written there.

If you are on Windows, you can simply get the .exe on GitHub as well.

So i ran the first chunk and I think it went through, but when I run the second it gives

error: failed to prepare transaction (could not satisfy dependencies)

I updated everything with pacman -Syuu like the troubleshooting website suggested.

I also used that .exe and FreeFEM still wont run the code you posted earlier. It gives this error

    Error line number 820, in file  macro: buildOverlapEdgePeriodicRecursive in C:\Program Files 
   (x86)\FreeFem++\\idp\macro_ddm.idp, before  token mpiWtime

You need to run FreeFem++-mpi.exe, not FreeFem++.exe, see this answer in another thread on how to use it from the command prompt.

Whenever I try to run FreeFem+±mpi.exe it immedietely closes. Is that something on my end?

Also what is the easiest way to edit code on my machine?

It closes the terminal? You may have to install MS-MPI. You can edit code using Notepad.


Looking at the install guide I have done steps 1-5 without error popping up. I have installed MPI, msys2, and Git. It yells at me whenever I try to do step 6, and I have gotten different answers about what I should actually put in their. Once everything is intalled I am still not sure how to get the mpi version of FreeFEM to run the code. Currently I have been editing code in the online widget and then downloading the .edp file at it runs automatically.

Sorry this is a lot I am just getting more confused about what I actually need to do and how.

Just open the Windows command prompt, go in the FreeFEM folder installation using cd, and type a command.

what command? I am here right now

Again, see the screenshots in this previously mentioned post for the correct path and commands.

I am not sure what commands you are referring to. I have a scipt.edp file dowloaded, how do I get it to run through FreeFem+±mpi.exe from the command prompt?

By typing "FreeFem++-mpi.exe" script.edp in the C:\Program Files (x86)\FreeFem++ folder.

I ran the code you posted in a different thread, but the plot doesn’t show pop up. Other than that I believe it is working.

Good! For the plot, I think this is a known problem. Maybe you could try the following:

  1. run the code with the option -fglut myPlots
  2. after completion, run "ffglut.exe" myPlots

But I’m not sure it will work as well. To be honest, you should just switch to ParaView. I can give you the appropriate command for your script if you want.

I dont need plots anymore, so that is more of a curiosity than anything. I am going to put the calculations I need to do in the code you provided, make sure it all works, and hopefully get it to run faster. If it doesnt work I will let you know, If it does I would like to bug you about what exactly you did so I can understand it.

Thank you so much for the help again.

Also is the website not loading more than two tabs a me problem or a server side problem?

Sure thing, please do let me know if you run into any hiccups or something is not clear to you. With the script I gave you, you can leverage parallel computing + SLEPc, which is more efficient than ARPACK. So the sky should be your limit! :smile:

W.r.t. the website, I’m not real sure what you mean. Maybe it is a little slow this morning?

1 Like