Identifier `savegmsh` does not exist

Hello, I am a newbie to FreeFEM++ and I’ve been learning it for some days. Here there is something wrong with the learning…


I ran across a problem that is

177 : savegmsh The Identifier savegmsh does not exist
Error line number 177, in file schrodinger-harmonic-oscillator-2d-SLEPc.edp, before  token savegmsh

when I was trying the example. I wonder if it requires me to compile it by myself in order to reconfigure it --with-gmsh or something else like it?

The full log is here.

My environment:

Running command: ff-mpirun -np 1 schrodinger-harmonic-oscillator-2d-SLEPc.edp > dump.log

FreeFEM++ version: 4.9

OS: macOS 10.15.6
Installation of FreeFEM++: downloaded from github release

'/usr/local/mpich3/bin/mpiexec' -np 1 --version
HYDRA build details:
    Version:                                 3.3
    Release Date:                            Wed Nov 21 11:32:40 CST 2018
    CC:                              clang
    CXX:                             clang++
    F77:                             ifort
    F90:                             ifort
    Configure options:                       '--disable-option-checking' '--prefix=/usr/local/mpich3' 'F77=ifort' 'FC=ifort' 'CXX=clang++' 'CC=clang' '--cache-file=/dev/null' '--srcdir=.' 'CFLAGS= -O2' 'LDFLAGS=' 'LIBS=' 'CPPFLAGS= -I/Users/hecht/work/soft/mpich-3.3/src/mpl/include -I/Users/hecht/work/soft/mpich-3.3/src/mpl/include -I/Users/hecht/work/soft/mpich-3.3/src/openpa/src -I/Users/hecht/work/soft/mpich-3.3/src/openpa/src -D_REENTRANT -I/Users/hecht/work/soft/mpich-3.3/src/mpi/romio/include' 'MPLLIBNAME=mpl'
    Process Manager:                         pmi
    Launchers available:                     ssh rsh fork slurm ll lsf sge manual persist
    Topology libraries available:            hwloc
    Resource management kernels available:   user slurm ll lsf sge pbs cobalt
    Checkpointing libraries available:
    Demux engines available:                 poll select

Is there anything else I should provide? Looking forward to your reply~

You probably need to add load "gmsh" to your script.

Thanks for the reply! I removed the savegmsh at the last line and it can run! Thank you.

May I ask an another question? It seems the plotMPI does not show any pictures or write them on disk. How can I make it work?
dump.log (303.7 KB)

use the option -wg “with graphics” :
FreeFem+±mpi -wg

OK, thanks for the reply, I can view the wave function now!

I found where the issue is:


It seems ff-mpirun adds -nw by default and that argument can be canceled by -win -wg.

It’s not an “issue”, it’s the default behavior with FreeFem+±mpi.

1 Like

OK. Thanks for the explanation!