3d mesh problem using readmesh3/savemesh in Windows 10


I am trying to import 3d mesh files from GMSH to FF++ and export the calculation results to Matlab for plotting. However, I found that under Windows 10, the program ends at the readmesh3 or savemesh function, even the format is INRIA MESH. For import mesh files, the gmshload3 function can be used in place of readmesh3 by changing the import file format to .msh.

I’ve also tried to run the matlab_octave_3d_examples under Windows 10, the program ends at savemesh function and exports an empty capacitor3d.mesh. However, when I run the same program under Debian11 it works fine.

I wonder to know if it is a bug of Windows and is there anyway to replace the savemesh function?


I think there are three formats which you can try to import a mesh generated with GMSH into FreeFem with the following commands:

    DM dm("mesh0.msh"); // GMSH version 4 ascii. This requires PETSc
    th = dm;
    th = gmshload3("mesh0.msh"); // GMSH version 2 ascii.
    th = readmesh3("mesh0.mesh"); // INRIA 

(I hope I do not messed anything up in the code above, I tried this a long time ago)

Thank you for your reply.

I think I didn’t ask my question clearly. It’s not about which mesh file format can be imported into FF++. My problem is that readmesh3 and savemesh functions are not working in Windows 10 system.

I think other users had the same problem a few days ago: